[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: E: pbuilder-satisfydepends failed.

On 2010-02-09 09:42 +0100, Mathieu Malaterre wrote:

> On Mon, Feb 8, 2010 at 4:06 PM, Sven Joachim <svenjoac@gmx.de> wrote:
>> On 2010-02-08 15:43 +0100, Charles Plessy wrote:
>>> Le Mon, Feb 08, 2010 at 02:28:38PM +0100, Sven Joachim a écrit :
>>>> On 2010-02-08 14:25 +0100, Charles Plessy wrote:
>>>> > libjpeg8-dev does not provide libjpeg-dev…
>>>> The latest version (8-2) does.
>>> So Matthieu only has to wait for version 8-2 to propagate to his favorite
>>> mirror…
>> Um, I think you're wrong.  Most likely his problem is that it has
>> already propagated -- this transition is responsible for the conflict
>> between libjpeg-dev and libjpeg62-dev.
> Sorry I do not understand that part.

What I mean is that since the latest libjpeg8 upload libjpeg-dev and
libjpeg62-dev are now provided by different packages, and they
conflict.  Before that, libjpeg62-dev used to provide libjpeg-dev.

> Can I work around bug #566514 ?
> Can I work around the libjpeg8 / libjpeg62 issue ?

You can switch the build dependency of your package to libjpeg-dev, but
I think you had already done this before you asked.  And you could try
to install sbuild and see if you can build your package with that.

If sbuild also gets unresolvable conflicts, there is probably not much
point in uploading anyway, because the buildds will not be able to build
your package either for the time being.

You can also ask the Debian GCC maintainers if they have plans to remove
the java-gcj-compat package from unstable to resolve #566514.


Reply to: