[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Exact debhelper dependency with format "3.0 (quilt)"

On Sunday 24,January,2010 04:26 AM, Mats Erik Andersson wrote:
> Hello all,
> I am converting my first two packages to format "3.0 (quilt)".
> Both these will be abandoning the "dh --with quilt $@" rule
> for "dh $@" now!
> Hence the build dependency on quilt can be eliminated, but what
> about debhelper? Is "debhelper (>= 7.0.50~)" the minimal version
> for this source format, or would "7.0.15" as in Lenny suffice?
> Best regards,
7.0.50 is needed if you use override_dh_* rules. Otherwise 7.0.15 should be fine
(I think even 7.0.0 would be fine for the dh7 rules style). Grep the debhelper
for the debhelper features you need. That should give you the exact version you
should put.

Kind regards,
Chow Loong Jin

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: