[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to write emacs dependency ?



On 2009-11-11 16:43 +0100, Christoph Egger wrote:

> TANIGUCHI Takaki schrieb:
>> Hi, 
>> 
>> I am maintainer of darcsum package.
>> 
>> It works on 
>>  * emacs21 + gnus
>>  * emacs22 
>>  * emacs23
>>  * xmacs21
>> 
>> I can't find how to write Depends field. I want to write such as
>> "Depends: (emacs21, gnus) | emacs22 | emacs23 | xemacs21".
>> --
>> 谷口 貴紀 (TANIGUCHI Takaki)    takaki@asis.media-as.org
>> http://takaki-web.media-as.org/ takaki@debian.org
>> 
>> 
>
> Depends: emacs21 | emacs22 | emacs23 | xemacs21,
>   gnus | emacs22 | emacs23 | xemacs21

This does not give you any guarantee that somebody trying to run darcsum
on emacs21 has the gnus package installed.

How about simply dropping support for emacs21?  It's an obsolete Emacs
flavor version that has been removed from sid already.

Sven

Attachment: pgpnGW_jWT5tm.pgp
Description: PGP signature


Reply to: