[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A libtool and automake question (for developing fuppes)

Robert Massaioli <robertm@cse.unsw.edu.au> writes:

> Recently I tried to build fuppes UPnP Media Server
> (http://fuppes.ulrich-voelkel.de/) but I came across the following
> error:

> bin/sed: can't read /usr/lib/libogg.la: No such file or directory
> libtool: link: `/usr/lib/libogg.la' is not a valid libtool archive

Usually libtool should just cope transparently and you don't need to do
anything.  The case when it doesn't, and what I suspect you're running
into, is when what you're building depends on some other library that does
have an *.la file, and that *.la file in turn references the (no longer
present) libogg.la file.

This happened to a lot of packages because the removal of libogg.la wasn't
as well-coordinated as it could have been, so the first step would be to
make sure that you're completely up-to-date on all the dev packages that
you're using.  If that still doesn't work, reporting here what libraries
your program is trying to link against should help in narrowing it down.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: