[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upload debian package error

Hi Sandro Tosi

Thanks for the reply.
I will try my best

Sandro Tosi wrote:
> Hello xiangfu,
> this kind of questions are better addressed to debian-mentors mailing
> list, adding it, and you also already received a reply [1] there.
> [1] https://lists.debian.org/debian-mentors/2009/06/msg00573.html
> On Wed, Jul 1, 2009 at 08:55, xiangfu<xiangfu.z@gmail.com> wrote:
>> Hi
>> I try to upload xburst-tools[1], I have two warning and one error.
> is this a new package? I can't find it in our archive or an ITP for it.
>> my question is
>> 1. the version number must 1.0.0(like that). can I use 2009.06(something like that to be a version)
> if upstream has a version standard, use that, bu you can also use
> dates for version.
> You have to create a non-native package, that's the reason for
> "source-nmu-has-incorrect-version-number"
> I think this question proves you didn't read debian policy, developers
> reference and new maintainers guide: please fill this gap of knowledge
> asap, and before asking further questions.
>> 2. I am not a maintainer. but I want to be this package's maintainer.
>>   can I add my name and email to the control file
> you MUST add your name if you want to be the maintainer. That's th
> reason for "xburst-tools source" lintian error.
>> 3. what am I got do with last warining.
> remove spuriours, auto-generated files in clean debian/rules target.
>> maybe I ignore some help page because My English is not very good.
> English is very important for debian communication, so I strongly
> suggest to improve your english.
>> So give me some advice or direct.
> Read teh doc I've mentioned above and use debian-mentors, not -devel.
> Regards,

Best Regards
Xiangfu Liu

jabber : xiangfu.z@gmail.com
skype  : xiangfu.z

Reply to: