[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: php-xml-util (updated package, 2nd try)

> > 
> > The package appears to be lintian clean.
> No, it's not.
> W: php-xml-util source: out-of-date-standards-version 3.7.3 (current is 3.8.2)

My fault, i just pasted the template suggested by the "My packages" area
at mentors.debian.net without checking it. As you can see at [1], the
system thinks that the package is lintian clean...


> Also, you should use a patch system when changing upstream source as
> suggested by lintian (pedantic, I know). What puzzles me is the change
> of the license in XML_Util-1.1.4/Util.php. It seems upstream stated
> "version 2.0 of the PHP license" while you changed it to 3.01. Any
> particular reason for that?

I'm intending to adopt this package ([2]), those changes was not made by
me. As stated in the changelog my changes has affected just the control
file, removing the previous uploader (he asked me to do so), removing a
lintian warning with ${misc:Depends} and modifying the section to match
the override stated at [3].

[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=529694
[3] http://packages.qa.debian.org/p/php-xml-util.html

What should i do to correct all this?

Thanks a lot,

Reply to: