[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RFS: hexer (adopted & updated package)



Dear mentors,

I am looking for a sponsor for the new version 0.1.4c-3
of my package "hexer".  This is an adoption - ITA #520635.
The changelog entry describing my update to the Debian packaging of
hexer is included a bit further down.

There's just one binary package:
hexer      - An interactive binary editor with a Vi-like interface

The package has been tested with lintian and pbuilder.

The upload would fix these bugs: 437160, 520635

The package can be found on mentors.debian.net:
- dget http://mentors.debian.net/debian/pool/main/h/hexer/hexer_0.1.4c-3.dsc

Some may have noticed that it is my custom to 1. fix all compiler
warnings in a package build, and 2. use the hardening wrapper.
For this particular case, I've chosen not to do that straight away
with the adoption; I'll probably adopt the upstream package itself
in the next day or two and bring that 13-year-old code up to snuff.
The problem is, the patch that fixes just -Wall -Wstrict-prototypes
was more than 120 KBytes long :)  IMHO, it'll better that I do this
as a new upstream release :)

Just for reference, here's my adoption changelog entry:

hexer (0.1.4c-3) unstable; urgency=low

  * New maintainer.  Closes: #520635
  * Use quilt for patch management.
  * Drop the README patch; with all due respect to Peter Mathiasson,
    in my humble opinion this information is addressed to developers,
    not end-users, and thus belongs right here, in the Debian changelog
    instead.
  * Add a watch file.
  * Fix up the manual page a bit:
    - use .\" instead of ./" for comments
    - properly use hyphens instead of minus-signs
  * Flesh out the long description with a list of hexer features.
  * Unbreak the "comment" and "argument" words in the help text to
    avoid spellcheck warnings from lintian.
  * Override the "no upstream changelog" and "no homepage field"
    lintian warnings.
  * Add the Vcs-Svn and Vcs-Browser fields.
  * Bump the debhelper compatibility version to 7:
    - add misc:Depends to the binary package
    - minimize the rules file
  * Bump Standards-Version to 3.8.1:
    - replace Apps with Applications in the menu section
    - honor the "nostrip" build option; Closes: #437160
    - override the compiler program and flags so the "noopt" build option
      is also honored
    - add the README.source file mentioning the use of quilt
  * Convert the copyright file to the machine-parseable format and
    add my copyright notice on the Debian packaging.
  * Build with -Werror if "werror" is specified in DEB_BUILD_OPTIONS.
  * Fix some compiler warnings.
  * Quote the "needs" and "section" menu file fields and install it.

 -- Peter Pentchev <roam@ringlet.net>  Fri, 03 Apr 2009 05:31:17 +0300

I would be glad if someone uploaded this package for me.

G'luck,
Peter

-- 
Peter Pentchev	roam@ringlet.net    roam@space.bg    roam@FreeBSD.org
PGP key:	http://people.FreeBSD.org/~roam/roam.key.asc
Key fingerprint	FDBA FD79 C26F 3C51 C95E  DF9E ED18 B68D 1619 4553
If the meanings of 'true' and 'false' were switched, then this sentence wouldn't be false.

Attachment: pgpMEkQQ7D8v3.pgp
Description: PGP signature


Reply to: