[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Listing dependencies with specific versions

On Tue, 9 Dec 2008 17:34:15 +0000 (UTC)
Andy Hawkins <andy@gently.org.uk> wrote:

> Now I'm confused. 

That's my fault. There is a bug in the shlibs of libflac++

> Is there a bug in the libflac++ stuff or not? The
> way I see it:

Yes - just in the shlibs which is much easier to fix.
> 1. If my software is compiled against libflac1.1.x, it won't include
> picture support, so will work with a version of libflac1.1.x *or*
> libflac1.2.x

Once libflac++ is fixed, dpkg-shlibdeps will pick up the right version
and give you the strict dependency that you need.

Until it is fixed, you can work around the bug but that won't protect
anyone else building against the library.

Your package should not be capable of being built against libflac1.1
because it should check for 1.2 in the configure stage. Your package
is what requires symbols from 1.2, your package needs to check for
that. Once built, if it is installed alongside 1.1 (despite being built
against 1.2), then it will fail because it is looking for symbols that
only exist in 1.2 - that is the bug in the library.
> 2. If my software is compiled against libflac1.2.x, it *will* include
> picture support so *won't* work with a version of libflac1.1.x, only
> libflac2.2.x

Yes. You need to ensure that it is built against 1.2.
> 3. When I build my package on testing, it compiles and links against
> libflac1.2.x. So, it includes picture support. *However*, the
> dependencies for the binary package only say it depends on libflac,
> no libflac >= 1.2.x

Which is the bug in the library that you can work around.
> Can someone confirm / deny my understanding here? As I say, I'm very
> new to all this.

Sorry to inflict my mistake upon you. It happens to everyone at some


Neil Williams

Attachment: pgphn9oMzJNsq.pgp
Description: PGP signature

Reply to: