[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: gnome-inm-forecast



OoO En  cette nuit striée d'éclairs  du lundi 02 juin  2008, vers 02:00,
Gustavo Iñiguez Goya <ga@kutxa.homeunix.org> disait:

> I am looking for a sponsor for my package "gnome-inm-forecast".

> * Package name    : gnome-inm-forecast
>   Version         : 0.6.1
>   Upstream Author : Gustavo Iñiguez Goya <ga@kutxa.homeunix.org>
> * URL             : http://kutxa.homeunix.org/trac/gnome-inm-forecast
> * License         : GPL
>   Section : gnome

Hi Gustavo!

You cannot start with 0.6.1-0 version. Use 0.6.1-1.

In  debian/control, you should  use blank  lines between  paragraphs and
bullets for lists:
 It displays the Spanish weather forecast on the GNOME panel, getting the 
 information from the Spanish Meteorological Agency (http://www.aemet.es).
 .
 Features:
  + Up to 7 days of meteorological information, including maximum and 
    minimum temperatures, rainfall probability, wind direction, snow 
    level and general weather state.
  + Snowfalls reports for the Pyrenees.
  + Intuitive city search just by typing the firsts characters.
  + Weather reports for the following days.
  + Maximum and minimum temperatures maps for the following day.
  + Spanish weather forecast image.
  + Satellite radar images of the weather evolution.

If you  can, you could  reword the short  description to avoid  to start
with an uppercased letter.  You can seek help in debian-l10n-english@ldo
if you want.

Check  copyright for each  files. Some  of them  are not  copyrighted by
yourself (even if they are licensed as GPLv2+).

You are shipping  an empty NEWS file as documentation.  I think that you
should not ship README either. This is more like a LICENSE file.

Your postinst file seems to do nothing. Remove it. As well for postrm.

You should clean up your debian/watch to just leave uncommented lines.

You can clean up a bit your debian/rules by:
 - removing the fact that the file is a sample one
 - removing CFLAGS stuff; this is now done by dpkg-buildpackage
 - remove commented dh_* calls

Your package does not compile in unstable:
checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.8) were not met:

Package xcb-renderutil was not found in the pkg-config search path.
Perhaps you should add the directory containing `xcb-renderutil.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xcb-renderutil', required by 'cairo', not found

Maybe this is a bug in libxcb-render-util0-dev?
-- 
BEANS ARE NEITHER FRUIT NOR MUSICAL
BEANS ARE NEITHER FRUIT NOR MUSICAL
BEANS ARE NEITHER FRUIT NOR MUSICAL
-+- Bart Simpson on chalkboard in episode 1F22

Attachment: pgpTwchZQjlwc.pgp
Description: PGP signature


Reply to: