[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITR: blam 1.8.4-3

On mar, 2007-12-11 at 08:52 -0600, Luis Rodrigo Gallardo Cruz wrote:
> Mmm. cdbs at work.
> Ok, if you can't get them to apply soon enough, it's ok to leave those
> (but just those) directly in the .diff.gz.

 As I explain in my response to Neil, there shouldn't be any non-debian/
parts in the .diff.gz left.

> A few more comments:
> dpkg-shlibdeps complains about many unnecesary libraries linked to
> libblam.so. It would be good if you could check upstream's build
> systema and try to eliminate them, but this is not a show stopper and
> can well wait for another release.

 That library is mostly a hack to talk to gecko. I'm slowly getting rid
of it, but I'll try to cut down on the linking meanwhile. The extra libs
are probably due to xulrunner's pkg-config.

> I get the following warning:
> dh_clideps: Warning! No Build-Depends(-Indep) on cli-common-dev (>= 0.4.4)!


> dh_clideps: Warning: Could not resolve moduleref: libblam.so for: blam.exe!

 dh_clideps is searching for libblam.so but we don't have the mono
library search dir variable set to include the dir libblam.so is in, so
it can't find it. This is harmless as we then run blam.exe from the same
directory as libblam.so is, so it doesn't need to be installed in an
easy-to-find place.

> dh_clideps: Warning: No Debian dependency data for Atom.NET (!

 This happens because the file clideps isn't being created. On the other
hand, I'm not allowed to run dh_makeclilibs because this is a private
library (mono policy 6.1.1). It's fairly harmless because no other
program links against it.

 That library on its way out and probably won't survive another revision
(it's already been replaced upstream by the mono equivalent of 'a small
shell script').

> I don't know enough about mono to know how serious these are, so
> please either fix them or explain to me why it's not needed ;)
> linda complains that:
> E: blam; Uses cdbs and debhelper.mk, but debhelper Build-Depends is too old.
>  This package uses cdbs and includes debhelper.mk, but the version of
>  debhelper the package Build-Depends on is too old.  To use
>  debhelper.mk you currently must Build-Depend on at least debhelper (>=
>  4.1.0).


> lintian complains that:
> W: blam source: out-of-date-standards-version 3.7.2 (current is 3.7.3)


> Please check if the new changes to policy apply to your package and
> update Standard-versions accordingly.
> W: blam: description-contains-homepage


> Please move the Homepage from inside the description into its own
> control field, which is now supported.
> I: blam: desktop-entry-contains-encoding-key /usr/share/applications/blam.desktop:3 Encoding


> That's for your upstream ;) .desktop files should no longer include
> the Encoding entry, it's now obligatory to encode them in utf8.
> (BTW. Always use the lintian from unstable to check your packages.)

 I do. I've just updated lintian but it won't give me those errors even
with -i. Do you use any other switches?

 The new package is at the same place as before. It shouldn't have any
problems now.

Carlos Martín Nieto    |   http://www.cmartin.tk
Hobbyist programmer    |

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: