[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dependancy question?

On Tue, May 15, 2007 at 10:18:11PM -0500, Paul Elliott wrote:
> Build-Depends: debhelper (>= 4.0.0), autotools-dev, libboost-dev, libboost-dev, libboost-regex-dev, libgconfmm-2.6-dev, libgtkmm-2.4-dev, libsigc++-2.0-dev, libboost-filesystem-dev (>= 1.33.1 ) libboost-regex-dev (>= 1.33.1 )
Why have two libboost-dev?
Also there is a libbost-regex-dev , one with a version and one without

> Depends: ${shlibs:Depends}, ${misc:Depends}, libgtkmm-2.4-1c2a, libgconfmm-2.6-1c2, libsigc++-2.0-0c2a, libboost-filesystem1.33.1, libboost-regex1.33.1
Unless you are doing strange things, this is wrong. Let the shlibdeps
work this out for you.

The problem can be that while a package, with a recompile, will work
absolutely fine with libfoo version 0.1 and 0.2, as they have the same
API, there may be some dynamic linking problems.  Hard coding the
library dependencies is almost always a bad idea and will bite you in
the end.

> I would like to say that peless depends on boost, libgtkmm 2.4, libgconfmm 2.6, and libsigc++ 2.0
> without being so specific about the versions. But there appears to be no way to
> do this, the versions seem to be built into the package names!
dpkg-shlibdeps will work out the right things for you, in the case of
abinary requiring a specific library and that's the way it should be

Generally try it without specifying the libraries and see if it looks
ok. Have a look in debian/peless/DEBIAN/config too and see if that finds
your dependencies.

 - Craig

Craig Small      GnuPG:1C1B D893 1418 2AF4 45EE  95CB C76C E5AC 12CA DFA5
http://www.enc.com.au/                             csmall at : enc.com.au
http://www.debian.org/          Debian GNU/Linux, software should be Free 

Reply to: