[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: binNMU safe and ${binary:Version} or ${source:Version}

On Fri, 2006-10-13 at 10:01:08 -0700, Steve Langasek wrote:
> On Fri, Oct 13, 2006 at 04:13:07AM +0300, Guillem Jover wrote:
> > On Tue, 12 Sep 2006 15:11:23 -0700 Steve Langasek wrote:
> > > The documentation for this probably belongs in debian-policy; current
> > > versions of policy seem to mention Source-Version, though, not the new
> > > substvars, and I'm not sure if anyone has submitted a patch for this?
> > I was waiting until after the etch release to send such patch. I'd
> > consider Source-Version to be now half-deprecated, due to it needing
> > a versioned Build-Dependency on dpkg-dev.
> But this is a versioned Build-Dependency that can be satisfied today in
> etch; I don't see any reason to delay updating policy.

Yes it can be satisfied, but if policy specifies that the field is
deprecated, people wanting to follow policy will start Build-Depending
on a versioned dpkg-dev, which I rather not see happening if not
strictly needed (like in case of non-binNMU safe packages).

Maybe this is a void concern that can be fixed by proper wording in
the policy, though. Another option could be to up the dpkg-dev version
in build-essential, thus avoiding completely the Build-Depends.


Reply to: