[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [RFH] Compiling a Gnome app / GTHREAD or XDamage error

On Thu, Mar 23, 2006 at 06:20:21PM +0100, Bastian Venthur wrote:
> Hi,
> I'm currently working on a small GTK2 app and while trying to compile it
> under a clean pbuilder environment, I get the following error during the
> config phase:
> checking for GTHREAD... configure: error: Byzanz requires GThread-2.0 >=
>  and XDamage >= 1.0 to compile.
> make: *** [config.status] Error 1
> Currently my package build-depends on: debhelper (>= 4.0.0),
> autotools-dev, libexpat1-dev, libxdamage-dev, libpanelappletmm-2.6-dev,
> intltool, libgtk2.0-dev
> I guess the problem has something to do with GTHREAD, but I have no Idea
> which package provides it or if it's already in my build-depends, why
> config does not recognize it.
> The ubuntu counterfeit seems to use the same build-depends, but he uses
> cdbs and it seems to work -- debian/rules is a three liner without any
> special options, so I guess I have to add something to the config-options.
> Any idea?
You can probably just run ldd on the result (compiled outside of
pbuilder) to figure out what libraries are used, and then apt-file or
packages.d.o to search for the package that includes it.  Or perhaps
check the configure script debug output (whatever it calls itself) to
see whats missing.

Note that the configure script could be buggy, and test for the
existence of something which isn't actually needed by the rest of the
compilation (this happened recently with the xlibs-dev transition).

gthread is in the libglib2.0-dev package (note recent
application-level bugs regarnding glib dynamic allocation, such as


Reply to: