[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lintian error about missing debconf dependency (which is not missing)

Michael Hanke <michael.hanke@gmail.com> writes:

> I'm preparing a package which uses debconf. When I run lintian on the
> package the following error is reported:

> E: arno-iptables-firewall: settitle-requires-versioned-depends config
> N:
> N:   Debconf only supports the SETTITLE command as of version 1.3.22. To
> N:   ensure upgrades work correctly, packages that use this new command
> N:   should declare a dependency on that version of debconf.
> N:

> The strange thing is, that I have the following line in the control file:

> Depends: ${misc:Depends}, iptables (>=1.2.11), gawk, debconf (>=1.3.22) | debconf-2.0

> There is clearly a versioned debconf dependency. The above line is
> expanded to the following when building the package.

> Depends: debconf (>= 0.5) | debconf-2.0, iptables (>= 1.2.11), gawk, debconf (>= 1.3.22) | debconf-2.0

> Does anybody know where the problem is?

I wonder if lintian is getting confused by the dependency added by
${misc:Depends} and missing the second dependency that is tighter.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: