[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Lintian error about missing debconf dependency (which is not missing)


I'm preparing a package which uses debconf. When I run lintian on the
package the following error is reported:

E: arno-iptables-firewall: settitle-requires-versioned-depends config
N:   Debconf only supports the SETTITLE command as of version 1.3.22. To
N:   ensure upgrades work correctly, packages that use this new command
N:   should declare a dependency on that version of debconf.

The strange thing is, that I have the following line in the control file:

Depends: ${misc:Depends}, iptables (>=1.2.11), gawk, debconf (>=1.3.22) | debconf-2.0

There is clearly a versioned debconf dependency. The above line is
expanded to the following when building the package.

Depends: debconf (>= 0.5) | debconf-2.0, iptables (>= 1.2.11), gawk, debconf (>= 1.3.22) | debconf-2.0

Does anybody know where the problem is?

Thanks in advance.



GPG key:  1024D/3144BE0F Michael Hanke
ICQ: 48230050

Attachment: signature.asc
Description: Digital signature

Reply to: