[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ppower4, java, and texive packages

Michael Koch <konqueror@gmx.de> wrote:

> On Fri, Dec 02, 2005 at 11:36:38AM +0100, Norbert Preining wrote:
>> Hi all!
>> I have a question concerning packaging stuff for texlive: we want to
>> include the ppower4 bundle, which consists of TeX input files, and of
>> some jar archive/java program for postprocessing of the pdf file.
>> Now the question is: How do I package this: Can I include all the stuff
>> and only Recommend: a java run time system? And if non is installed,
>> give a warning message? Or should I leave out the postprocessor and only
>> include the sty files (which would of course make it more or less
>> useless)?
> Why not Depends on java1-runtime | java2-runtime | kaffe ?

Because ppower4 would be part of texlive-pdfetex, and provide only one
small aspect of its functionality.  Clearly a Depends is too
restrictive.  If i would use texlive (as teTeX maintainer, I'll
obviously stick to teTeX), I would for sure install texlive-pdfetex, but
not use ppower4 at all (I use beamer instead which doesn't require any
program for post-processing).  Therefore, from my POV it should be

A wrapper script that gives a nice warning would be great; but be
careful to actually deliver the warning to the user if the ppower4
postprocessor has a menu entry.

> For kaffe you can depend on another free runtime like sablevm or
> java-gcj-compat too.

Does ppower4 run with any of the free runtimes?

Regards, Frank
Frank Küster
Inst. f. Biochemie der Univ. Zürich
Debian Developer

Reply to: