[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc best practices | problems

On Sat, 29 Oct 2005, skaller wrote:
> compiler ABI changes (I believe that doesn't apply here since
> gcc 4.x uses same C ABI as gcc 3.4, not sure about C++ though)

There is a fatal C++ ABI change from 3.4 to 4.0.  All C++ code in Debian has
to be updated to compile with 4.0 now (if it uses libraries), or it will be
eventually be purged from the archive.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Reply to: