[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Help request] packaging pyne 1.0.3 - build problem


I am currently sitting at the last stable pyne version 1.0.3. But I
observe a problem, when I run debuild:

CFLAGS="-Wall -g -O2" ./configure --prefix=/usr
checking for python... yes
Checking python version >= 2.2.0... yes (2.3.5)
Traceback (most recent call last):
  File "<string>", line 3, in ?
  File "/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
    from _gtk import *
RuntimeError: could not open display
configure: error: GTK+ version >= (2,0,0) required
make: *** [config.status] Error 1

Everything works fine running 'dpkg-buildpackage -rfakeroot'. So if
someone could have a look at the problem, it would be really nice,
because I'm not sure, if I understand, why it fails. I guess it's an
authentication problem from the session management, but I don't know, if
that's the wanted behaviour in python2.3-gtk2. Maybe I can workaround
this problem. Anyone with an idea? I made an archive, which contains my
work: http://debian.wgdd.de/temp/pyne-1.0.3-package.tar.gz

Any help is appreciated.

Regards, Daniel

Reply to: