[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS capisuite and sfftobmp

On Sat, 2004-04-10 at 12:53, Daniel J. Priem wrote:
> Hello just repacked the following packages
> http://www.mpe.mpg.de/~ach/debian/
> capisuite and sfftobmp
> website is http://www.capisuite.de



Well, actually there is some problems with your package.

- libcapi20-2 should be in the Build-Depends line, otherwise:

checking for capi20_register in -lcapi20... no
configure: error: libcapi20 not found

- Standards-Version should be 3.6.1 instead of 3.5.2

- Your debian/rules, needs more work. I mean, remove unnecessary
comments, check the ./configure options, etc.

- This program requires a manpage. Please create one for this package.

Note: Most of this problems, can be detected using a Debian package
checker, like 'lintian' or 'linda'. To check dependencies problems, you
could use pbuilder, or setup a minimal chroot environment to test your
package. Check [1] to know how to do this. .

[1] http://people.cintegral.cl/~bruno/chroot.pdf

That's for start.

Midway upon the journey of our life,
I found myself within a forest dark,
For the straightforward pathway had been lost.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: