[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pbuilder on Woody

On Sat, Feb 28, 2004 at 08:52:44AM +0100, Frank Küster wrote:
> Bartosz Fenski aka fEnIo <fenio@o2.pl> schrieb:
> > Hello.
> >
> > Is it possible to run Sid chrooted environment on Woody?
> > I've tried to do it with pbuilder, but unfortunatelly I've failed :/
> >
> > Firstly, debootstrap had too old /usr/lib/debootstrap/scripts/sid
> > script, so I've changed it to the proper script from Sid.
> >
> > Then I've got segfault while configuring base-files package.
> >
> > What am I doing wrong?
> Using old software :-|
Well, whole Woody is quite old ;)

> I am using pbuilder backported from unstable (in fact I'm using 0.94),
> together with some other backports and
> to work around a bash bug. 
Hmmm, I've tried to use backported pbuilder and debootstrap, but it
doesn't help. 

> By the way, there's also the possibility of keeping a permanent
> chroot. While pbuilder is best for verifying build-dependencies and
> preventing other FTBFS bugs, a permanent chroot is much more convenient
> for application testing purposes: It's much faster to do just
> Ctrl-Alt-F8 instead of untarring - working/building - retarring. There
> is a short explanation in 
> http://www.debian.org/doc/manuals/reference/ch-tips.en.html#s-chroot
Yep, Matthew McGuire pointed it out for me. He told me to set up Woody
environment first, and then upgrade it to Sid.
I've tried it and failed again :/
After replacing glibc tar has started segfaulting, and now I can't
install/reinstall anything :/

Here goes example:
serwer:~# apt-get install strace
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 92  not
Need to get 0B/77.2kB of archives. After unpacking 217kB will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = "pl_PL.ISO-8859-2",
        LANG = "pl_PL.ISO-8859-2"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
dpkg-deb: subprocess tar killed by signal (Segmentation fault)
dpkg: error processing /var/cache/apt/archives/strace_4.5-1_i386.deb
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I think that it isn't related to this LOCALE issue. 
> (including how to set up init to get a login prompt on Terminal 8), and
> there used to be a short pdf document around somewhere, where it is
> described how to even get an xdm/kdm/whatever login. Ah, there it is:
It's unnecessary for me. I'm doing everything remotely, and in fact
I need this environment to run dedicated server for the game netpanzer.
> http://javierlinares.com/debian/docs/chroot/chroot.pdf
> The only thing that's missing in these docs is that I found one has to
> manually unmount the chroot proc filesystem. I created an init script:
> ~$ cat /etc/init.d/umountchrootproc
> #! /bin/sh
> #
> # umountchrootproc      unmount proc in chroot, so that the parent partition can be unmounted
> #
> PATH=/sbin:/bin:/usr/sbin:/usr/bin
> CHROOT_PROC="proc-sid"
> case $1 in
>     start|stop)
>     echo -n "Unmounting chroot proc mounts... "
>     for proc in $CHROOT_PROC; do
>         umount $proc 
>     done
>     echo "Done."
>     ;;
>     *)
>     ;;
> esac
Thanks. I'll probably use it when I will have working environment ;)


ps. sorry Frank for private mail, I've just resent it to the list.

      _     Bartosz Feński aka fEnIo | mailto:fenio@o2.pl | pgp:0x13fefc40 
    _|_|_    32-050 Skawina - Głowackiego 3/15 - w. małopolskie - Polska
    (0 0)     phone:+48501608340 | ICQ:46704720 | GG:726362 | IRC:fEnIo
ooO--(_)--Ooo http://skawina.eu.org | JID:fenio@jabber.org | RLU:172001

Attachment: signature.asc
Description: Digital signature

Reply to: