[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Standards-Version



On Thu, Dec 11, 2003 at 05:31:51PM -0500, Matt Zimmerman wrote:
> On Thu, Dec 11, 2003 at 11:00:45PM +0100, Florian Zaehringer wrote:
> 
> > I am planing to adopt my first package (emelfm, orphaned). So I checked
> > what needs to be done to equip myself for this task.
> >
> > There seems to be one current problems with that package: ToDo says the
> > TheStandards-Version is too old 3.5.2. Should be 3.6.1.
> >
> > So I wonder how I can do that? Is there some ChangeLog for the Debian
> > Policy? Does somebody know where I can find the right docs? Or
> > better: Does somebody perhaps know what needs to be done for a simple
> > gtk-program to be moved from 3.5.2 to 3.6.1?
>
> /usr/share/doc/debian-policy/upgrading-checklist.txt.gz

Which can be found in the debian-policy package. Which can safely be
installed from unstable, even on non-unstable systems (as far as I can
tell; I keep that one package manually up to date, since I develop on a
woody system and use pbuilder to run my builds/lintian/linda checks).

Have I mentioned lately how much I love pbuilder hooks? :)

Now, to get the NetBSD port up to the point that I can make pbuilder-bind
(bind-mounts /var/cache/pbuilder/build/<process> on top of a single
unpacked copy of base.tgz, rather than unpacking the tarball every time -
saves an unbelieveable amount of time on systems with only moderately fast
disks).
-- 
Joel Baker <fenton@debian.org>                                        ,''`.
Debian GNU NetBSD/i386 porter                                        : :' :
                                                                     `. `'
				                                       `-

Attachment: pgp6XmmOof0fZ.pgp
Description: PGP signature


Reply to: