[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel Patch Packages with -ac patches

On Thu, 14 Mar 2002 21:22, Ian Duggan wrote:
> > Why does the patch require 2.4.13-ac7?
> >
> > Why would you want to support an ancient pre-release of the kernel
> > anyway?
> >
> > Why doesn't it apply against 2.4.13?
> It doesn't just have patches for 2.4.13-ac. I have patches for most of
> the kernels between 2.4.4 and 2.4.18, as well as 2.5.1 through 2.5.6 in
> there.

In my kernel patch packages I dumped support for <=2.4.9 when it was 
discovered to have security holes.

Then 2.4.10 had Ext2/Lilo issues so I dumped support for it.

Now for my 2.4-lsm package I only support 2.4.16 and above (actually the 
2.4.16 patch should work from about 2.4.12 as well - but I haven't tested 

> I did the version using -YYYYMMDD as well, to make the upgrading happen
> correctly. That's an allowable way to do it, right? I didn't want to
> version it as -2.5.6, since people might not realize it had the other
> patches in it as well.

I think it's best to version it with the release date.

If you send email to me or to a mailing list that I use which has >4 lines
of legalistic junk at the end then you are specifically authorizing me to do
whatever I wish with the message and all other messages from your domain, by
posting the message you agree that your long legalistic sig is void.

Reply to: