[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing custom packages

mburr@programmer.net (Gai Sum) writes:

> robbe@orcus.priv.at (Robert Bihlmeyer) wrote in message news:<87hevtgy67.fsf@orcus.priv.at>...
> > mburr@programmer.net (Gai Sum) writes:
> > 
> > > I've managed to build the latest (unstable) version of postfix on my
> > > Potato box (with some difficulty.) I now cannot install it:
> >  [...]
> > > Can't locate Debconf/Client/ConfModule.pm in @INC (@INC contains:
> > > /usr/lib/perl5/5.005/i386-linux /usr/lib/perl5/5.005
> > > /usr/local/lib/site_perl/i386-linux /usr/local/lib/site_perl
> > > /usr/lib/perl5 .) at /var/lib/dpkg/tmp.ci/config line 7.
> > 
> > Well, debconf (which is the current potato version, AFAIK)
> > has "/usr/lib/perl5/Debian/DebConf/Client/ConfModule.pm" which should be
> > ok. Do you perchance have a newer debconf version installed?
> Actually, debconf 0.9.81 (testing) requires perl-base (>= 5.6.1-5)
> which leads to a great-big upgrade snowball. I was hoping that there
> might be a way to massage the source package into compiling and
> installing without having to upgrade much else.

Strange thing is, I don't see how postfix would depend on a specific
debconf version -- it's not due to its Depends, but a hidden dep could
exist. E.g. /var/lib/dpkg/info/postfix.config say:

        use Debconf::Client::ConfModule qw(:all);

and this should work fine with debconf, because
/usr/lib/perl5/Debconf/Client/ConfModule.pm should be found since
/usr/lib/perl5 is in your @INC. Does

        perl -MDebconf::Client::ConfModule -e42

work for you (shows no errors)? What debconf version do you have, now?


Attachment: signature.ng
Description: PGP signature

Reply to: