[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Package checking

On Fri, Feb 23, 2001 at 08:30:49AM -0800, Sean 'Shaleh' Perry wrote:
> On 23-Feb-2001 Sam TH wrote:
> > I'm an illustrious member of the NM queue, and have completed a
> > package that I would be very grateful if people would check for me, to
> > make sure that I haven't missed anything. It produces no errors or
> > warnings with lintian.  
> > 
> > The package is uf-view, and it's a GNOME based viewer for the User
> > Friendly comic strip.  Packages are available (src and i386) at
> > 
> >     deb http://samth.dyndns.org/debian ./
> > 

Thanks for checking this.  

Newly updated package available at 

    deb http://samth.dyndns.org/debian ./
    deb-src http://samth.dyndns.org/debian ./           

> $ lintian --version
> Lintian v1.20.6
> $ lintian uf-view_1.2-2_i386.changes
> E: uf-view source: package-uses-debhelper-but-lacks-build-depends

Fixed, I think.  I removed every possibly related package I could find
from my chroot, and then tried to build uf-view.  I had to ask apt-get
to install only: libgnome-dev, libghttp-dev and debhelper, but those
brought in close to 50 other packages (all of X and GNOME, for
example).  Are those three all that is needed for Build-Depends?

> since INSTALL is gzipped, my INSTALL file check fails, thanks for finding a bug
> in lintian (-:

You're welcome.  But you can't check it against my package anymore,
since the INSTALL file is now gone.  

> since you have NEWS saved as changelog.gz, NEWS is redundant.


> you also fail to install a menu file.  I am coming up with a lintian check for
> packages linked to X and not installing one.  So you reminded me of another bug
> (-:


Now I get the following lintian output:

samth# lintian --version
Lintian v1.20.6
samth# lintian -i uf-view_1.2-2_i386.changes
W: uf-view source: newer-standards-version

I presume this is a lintian bug.  Right?

On a somewhat related note, what would cause the following apt errors?
Dpkg installs the package without complaint, and apt's math seems to
be a little off.

Sorry, but the following packages have unmet dependencies:
  uf-view: Depends: libgtk1.2 (>= 1.2.8-3) but 1.2.9.cvs20010223-1 is
to be installed
           Depends: xlibs (>= 4.0.1-11) but 4.0.2-7 is to be installed


	sam th		     
	GnuPG Key:  

Attachment: pgpQHgSrfNW0T.pgp
Description: PGP signature

Reply to: