[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lintian: binary-has-unneeded-section



On Fri, Feb 02, 2001 at 11:17:23PM +1100, Drew Parsons wrote:
> Getting back to the meschach libraries, which I was asking about a little
> while ago, when I run lintian on the built packages, I get the following
> error report: 
> 
> W: meschach-dev: postinst-has-useless-call-to-ldconfig
> W: meschach: binary-has-unneeded-section ./usr/lib/libmeschach.so.1.2 .note
> W: meschach: binary-has-unneeded-section ./usr/lib/libmeschach.so.1.2 .comment
> 
> 
> I got no idea whatsoever what the second two messages mean.  I'm compiling
> the library with flags -fPIC to get a shared library.  What's all this about
> uneeded sections, notes and comments?
> 
sorry, i cannot help you, anyway have you tried lintian -i? it is a little more
verbose about its outputs.

cheers

-----[ Domenico Andreoli, aka cavok
 --[ http://filibusta.crema.unimi.it/~cavok/gpgkey.asc
   ---[ 3A0F 2F80 F79C 678A 8936  4FEE 0677 9033 A20E BC50

Attachment: pgpSedX9UBCrE.pgp
Description: PGP signature


Reply to: