[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build problem with `debuild -rsudo' and LD_LIBRARY_PATH



On Sat, 25 Nov 2000, Steve Dobson wrote:
> The make files use LD_LIBRARY_PATH to pick up the libraries that have just been built.
> However, as I run `debuild -rsudo', the LD_LIBRARY_PATH is of course ignored as the 
> building is being performed as root (why? -- isn't this a bug?), and the execution of

For security reasons. LD_LIBRARY_PATH is an one-step root compromise if a
user can set it and then run a suid root binary... Therefore ld.so ignores
it when root, and only links to libraries configured as trusted (i.e. in
directories listed in /etc/ld.so.conf).

> Is there a standard way of getting around this method in debuild?

I don't know if there is an standard method, but have you tried building the
package as non-root under fakeroot?  Maybe that'll do the trick.

> Should I raise a bug against devscripts as compiling of libraries and commands
> shouldn't be done as root?

Well, I also loathe building things as root, and fakeroot has been doing the
trick for me for a while. Try it before filing the bug, because one would
have to code a lot of stuff to get around the need to build .debs as a
normal user (i.e.: non-root and not under fakeroot) AFAIK.

-- 
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Attachment: pgpe86Si6TYsE.pgp
Description: PGP signature


Reply to: