[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Signing my package using pgp

    I had gnupg installed, but no key generated (and I can't generate one
at the moment for security reasons), so I am trying to use pgp to sign
with.  I ran 
dpkg-buildpackage -rfakeroot
and got an error emssage, saying there was no key for my email address,
which is right, because it was using gpg.  I tried    
dpkg-buildpackage -rfakeroot -spgps
dpkg-buildpackage -rfakeroot -ppgps -spgp
and both times got the error message 

signfile htp_1.11-1.dsc
Unrecognized option -s

SO then, I gave up and removed gnupg from my machine entirely and tried 
dpkg-buildpackage -rfakeroot
which built the package, but didn't sign anything

What am I doing wrong?

Robert King, Australian Environmental Studies, Griffith University, Australia
Currently on Research leave (returning to Australia, end of January 2001)
contact me by email
Robert.King@mailbox.gu.edu.au   http://www.ens.gu.edu.au/robertk/

"How should I know if it works?  That's what beta testers are for.  I only
coded it."
(Attributed to Linus Torvalds, somewhere in a posting)

Reply to: