[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Which are the permitions for /dev/tty?


I seem to have a little trouble with pgp/gpg and /dev/tty permitions.
My /dev/tty device was like this:

root:/dev $ ls -l tty
crw-r--r--   1 root     sys        5,   0 Mar  6 17:26 tty
root:/dev $

And pgp/gpg were breaking with permitions errors with /dev/tty. So tried this:
add my account to the group 'sys', and changing /dev/tty to be group write,
like this:

root:/dev $ ls -l tty
crw-rw-r--   1 root     sys        5,   0 Mar  6 17:26 tty
root:/dev $

Now, everything works, but I'm not very convinced that this is the right way
to work thing out.

BTW, I'm using kernel 2.2.2-ac7, but I've tried this 2.0.35, 2.0.36, 2.2.1,
2.2.2-ac4 and it gives the same result with all of them.

Can anybody out there just reasure that this is ok, _or_ if this is not
ok, then just give any ideia as to what might be happening?

Pedro Guerreiro (aka digito)    (pguerreiro@bigfoot.com)
Diplomacy: the art of letting someone have your own way.

Reply to: