[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dpkg-shlibdeps: error: cannot find library (Was: Bug#977308: shasta: hardcoded dependencies on boost 1.71)


I tried no override_dh_shlibdeps in shasta debian/rules, which has lead

dpkg-shlibdeps: error: cannot find library /usr/lib/python3/dist-packages/shasta.cpython-39-x86_64-linux-gnu.so needed by debian/shasta/usr/bin/shasta (ELF format: 'elf64-x86-64' abi:      '0201003e00000000'; RPATH: '')
dpkg-shlibdeps: error: cannot continue due to the error above
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to use -l.
dh_shlibdeps: error: dpkg-shlibdeps -Tdebian/shasta.substvars debian/shasta/usr/bin/shasta returned exit code 2
dh_shlibdeps: error: Aborting due to earlier error

and in the pbuilder chroot I also tried the there commands I added to
the comment in 


with no success - dpkg-shlibdeps simply did not found the shared library
which exists at the said place.  I wonder what might be wrong here and how
to fix this.

Kind regards


On Fri, Dec 18, 2020 at 06:03:30PM +0530, Nilesh Patra wrote:
> Hi Andreas,
> On Fri, 18 Dec 2020 at 15:53, Andreas Tille <andreas@fam-tille.de> wrote:
> > Control: tags -1 help
> >
> > Hi,
> >
> > I tried to fix the issue by making dh_shlibdeps work.  In
> >
> >
> > https://salsa.debian.org/med-team/shasta/-/commit/366edd672be428cc553b34b99bc614aa698175d6
> >
> > I documented what I tried but all failed and I think the key to this bug
> > is just making it work.
> >
> > Any idea?
> >
> I've no clue. The "-l" flag doesn't seem to work somehow. May I suggest
> forwarding it to the list? I'm positive that Aaron (ucko) will definitely
> know a good workaround for this bit.
> Also another request: Could you please as well attach the failing logs in
> future RFHs? This saves atleast one build for the others. Consider my best
> of intentions.
> Regards


Reply to: