[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: gasic



Hi Andreas, 
I've created another binary called gasic-examples and moved all examples there. 

I ran the tests again, and they all pass in my chroot. I also rebuilt the chroot in case there was something wrong there, and turns out they still pass. I also tried adding:
     bowtie-build dwv.fasta dwv.fasta
to the autopkgtests for the bowtie package, and all of those pass too. 

For the purpose of completing autopkgtests for gasic, I have tried to circumvent this issue by changing the mapper for gasic from bowtie to bwa, so bowtie will no longer be required for testing gasic.
I've also fixed a patch and added some more tests.

Please take a look - specially at the new binary (in case I've misplaced some file) - and if these tests work now, please sponsor. 

Regarding bowtie, I'm unable to reproduce the issue, so if you have any ideas that I can try, please let me know.

Regards,
Pranav


On Sun, May 10, 2020 at 10:53 AM Andreas Tille <andreas@an3as.eu> wrote:
Hi Pranav,

On Sun, May 10, 2020 at 02:58:32AM +0530, Pranav Ballaney wrote:
> I've added autopkgtests to gasic. Please review and sponsor.
> https://salsa.debian.org/med-team/gasic/

thank you for adding this test.  There is one cosmetic issue and a
problematic issue.  The cosmetic thing is that the additional data are
blowing up this quite small package a lot.  I do not think that we
should bloat user machines too much.  Thus it would be better to ship
the data in an extra binary package gasic-examples.

But here comes the harder part:  I get

autopkgtest [05:12:46]: test run-unit-test: [-----------------------
/tmp/autopkgtest.qJbg1v/tree/debian/tests/run-unit-test: line 23:   903 Segmentation fault      bowtie-build dwv.fasta dwv.fasta
autopkgtest [05:12:47]: test run-unit-test: -----------------------]

in my pbuilder chroot.  I remember I once had a similar issue with
bowtie before.  Its a bit hard to seek in BTS and I have no idea
whether it makes sense to seek at all.  But it would be great if you
could reproduce this somehow and we could debug that issue - which
is probably an issue in bowtie - it just should not segfault.

Kind regards

      Andreas.

--
http://fam-tille.de


Reply to: