[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: cgview

Hi Andreas,

On Sun, May 10, 2020 at 1:21 AM Andreas Tille <andreas@an3as.eu> wrote:
Hi Pranav,

On Sat, May 09, 2020 at 09:54:56PM +0530, Pranav Ballaney wrote:
> I've added autopkgtests to cgview. Since the output is an image, I haven't
> compared it to a reference - is that alright?

Its definitely better than nothing.

> If not, how do we usually test packages like this? I tried running a diff
> but that reported the files to be different, even though they were visually
> the same.

I somehow thought there are some image comparison packages inside Debian.
A short search has lead me to


which recommends

   identify -quiet -format "%#" images...

> Please take a look and let me know if any additional steps are required.
> https://salsa.debian.org/med-team/cgview

Please note that I used xz compression on the xml data to save some
space also on developers machines.  I've also called routine-update -f
to update the packaging.  I do not think that the image comparison is
mandatory here - its way better to test at all than to make it perfect.
But if you want to give identify a try that would be fine.

Okay then let's leave the test here. Thanks for the compression, I'll keep that in mind for future tests.

However, we have a remaining problem in my pbuilder chroot:

autopkgtest [19:32:42]: test run-unit-test: [-----------------------
run-detectors: unable to find an interpreter for /usr/bin/cgview
autopkgtest [19:32:43]: test run-unit-test: -----------------------]
autopkgtest [19:32:43]: test run-unit-test:  - - - - - - - - - - results - - - - - - - - - -
run-unit-test        FAIL non-zero exit status 2

This is weird - all tests pass in my chroot. Could it be like the issue we had with loki a few months ago?
It worked perfectly on Liubov's machine too. 

@Nilesh, could you please take a look here? 
It somehow sounds similar to this thread:


I'd recommend to check with debian-java@lists.debian.org .  In
the case of artfastqgenerator I've circumvented the problem
a wrapper script.

Let's let Nilesh try it once, and if the problem persists, we'll take it up with the Java team.


Reply to: