[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CI for kraken

Hello Andreas, 

I can see a git repository jellyfish1, but I'm not sure how to tell kraken to use this particular package. 
I tried to write jellyfish1 in debian/control Depends and it didn't work. Also I tried jellyfish (= 1.1.5-1) and it still gives the same error message.
And when I try just jellyfish it doesn't work again with message 

Found jellyfish v2.2.6
Kraken requires jellyfish version 1

Sorry, I must be missing something important.

Regards, Nadiya

On Thu, Jul 20, 2017 at 12:54 AM, Andreas Tille <andreas@an3as.eu> wrote:
(as you might have seen from commit logs I've done some

   for i in `git tag | grep '/2'`; do git tag -d $i; git push origin :refs/tags/$i ; done

to remove useless tags)

On Thu, Jul 20, 2017 at 09:46:15AM +0200, Andreas Tille wrote:
> Hi Nadiya,
> On Wed, Jul 19, 2017 at 08:09:19PM -0700, Nadiya Sitdykova wrote:
> > Unfortunately your explanation wasn't sufficient for me.
> > Do you mean that I should clone both jellyfish and jellyfish1, than copy
> > jellyfish git file to the jellyfish1 directory?
> > And than how can I checkout the latest release of version 1 and make this
> > new master?
> I'm not a Git expert but I did the following - may be there is a more
> efficient way to do things.
>   cp -a jellyfish jellyfish1
>   cd jellyfish1
>   git reset --hard debian/1.1.5-1
>   sed -i 's/jellyfish/jellyfish1/g' debian/control
>   vi debian/control # doing some manual fixes in debian/control
>   cme fix dpkg-control
>   dch -i
> -->
> jellyfish1 (1.1.5-1) UNRELEASED; urgency=medium
>   * Create separate jellyfish1 package since there exist packages that
>     explicitly require jellyfish version 1
>  -- Andreas Tille <tille@debian.org>  Thu, 20 Jul 2017 09:16:24 +0200
>   git commit -a -m"create jellyfish1 package"
>   git checkout upstream
>   git reset --hard upstream/1.1.5
>   git checkout pristine-tar
>   git reset --hard 8b4a53ecb71b5739d050fbb926c5298840318093
>   # this goes down to the import of 1.1.11 which is the latest version of the 1.x series
>   vi .git/config
>   # this is a hack since I have no idea about all those Git settings.  I simply left
>   # the [core] section and used my inject-into-alioth-git script which creates a new
>   # repository on aliot ( https://anonscm.debian.org/viewvc/debian-med/trunk/helper-scripts/inject-into-alioth-git?view=markup )
>   inject-into-alioth-git
>   # forgot to remove branches
>   git branch -D debian/jessie-backports
>   git push origin :debian/jessie-backports
>   git branch -D libjsoncpp
>   git push origin :libjsoncpp
>   # fix pristine-tar branch
>   git checkout pristine-tar
>   for i in jellyfish_* ; do git mv $i `echo $i | sed "s/^jellyfish/&1/"` ; done
>   git commit -a -m"Rename pristine-tar information files"
>   git checkout master
>   # after realising that upstream branch seems not to fit 1.1.11
>   # reimport this tarball, deleting upstream/1.1.11 tag first
>   git tag -d upstream/1.1.11
>   git push origin :refs/tags/upstream/1.1.11
>   uscan --verbose --force-download
>   gbp import-orig --pristine-tar ../jellyfish1_1.1.11.orig.tar.gz
> This leads IMHO to some workable Git repository of 1.x series of
> jellyfish.  I also added a commit to fetch only 1.x series in watch
> file.  Now the task is to redo some packaging changes like separating
> libjellyfish-1.x - but only in case this would be really needed for
> kraken.  There is no point in over-engineering.  Our fokus should be
> to get kraken reliably working and not copying jellyfish 2.x layout
> since this is most probably not used and just draining time.
> I tested as far that gbp-build now starts building but there is some
> issue in the build time tests.  To clean up the repository it might be
> sensible to remove all tags refering to 2.x series.
> Do you think you can continue from here and check, whether kraken
> works with the resulting package?  If something remains unclear feel
> free to keep on asking as usual.
> Kind regards
>       Andreas.
> --
> http://fam-tille.de


Reply to: