[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Update on Trinityrnaseq packaging

On Fri Feb 13 2015 at 12:55:49 AM Andreas Tille <andreas@an3as.eu> wrote:
[Reply to list only]

We are oppositely calibrated :-D I prefer to be CC'd even when I am a subscriber and you don't. 

> On Thu, Feb 12, 2015 at 09:42:45PM +0000, Michael Crusoe wrote:
> > > > - [ ] binary-without-manpage usr/bin/Trinity
> > >
> > > Same as above.  It would be nice to have (even nicer than hardening)
> > > there are cases where it is hard to write a sensible manpage.
> >
> > I've produced one with help2man.

> That's usually the cheapest way and fine for the most cases.
> Unfortunately it did not worked in this case - I commited a manually
> edited manpage based on yours.  The result at least fits nroff syntax.
> :-)

> >  * trinity-plugins/Trimmomatic-0.32: Binary without source!
> >    Trimmomatic is packaged in this version anyway - so this should
> >    be simply dropped via Files-Excluded
> >
> Done

OK - but the dir remains in the Git repository.  You should import
a cleaned up archive.  You can get this by

    debian/rules get-orig-source

... or if you want to save your bandwidth via

    mk-origtargz --repack --compress xz <path_to_original_download_source>

Yeah, I had tried that; I get this head-scratching response:

mcrusoe@athyra:~/debian/trinityrnaseq$ mk-origtargz --repack --compress xz ../v2.0.3.tar.gz 
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/jung-graph-impl-2.0.1.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/jung-api-2.0.1.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/jung-algorithms-2.0.1.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/java-getopt-1.0.13.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/collections-generic-4.01.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/src/lib/Jaligner.jar: Not found in archive
tar: trinityrnaseq-2.0.3/Butterfly/prev_vers/Butterfly_r2013_08_14.jar: Not found in archive
tar: Exiting with failure status due to previous errors

(I checked and they do exist)
> >  * trinity-plugins/fstrozzi-Fastool-7c3e034f05: While mentioned
> >    properly in d/copyright I'd at least refer to the download
> >    location
> >      https://github.com/fstrozzi/Fastool
> >    in a Comment: field.  I'd regard it as the better solution to
> >    create a separate package since it might be considered useful
> >    for people not only using it via trinityrnaseq
> I've added the comment. As for packaging it separately I'll leave this to
> some other motivated individual to do so. There are a lot of bioinformatics
> libraries that are functionally single use.

May be I'll care for this in some MoM project.  Usually these small
tools are easy targets and than it should be done also for the sake of
separate testing.

Have fun!

> >  * trinity-plugins/parafly/src/ParaFly.cpp:
> >     Authors of this wrapper are MB Couger (mbcouger(AT Symbol)gmail.com,
> > Matt Stowe mstowe(AT Symbol)okstate.edu
> >    This should at least deserve an extra d/copyright line and you
> >    should also dig for the original download location.  I can
> >    not evaluate the sense of a separate package.
> >
> Nothing coming up. Probably Broad Foundation employees / interns. I think
> they are covered by the existing entry.

Finally it does not matter what you think but what you can convince
ftpmaster to accept. ;-)

Indeed, but it'll get properly packaged with transdecoder. Lacking an upstream distribution site makes a pretty clear case for not having its own package.

Reply to: