[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#629815: No rule to make target `/usr/lib/libdl.so'

Hi again,

to give an update to this problem:

On Fri, Jun 10, 2011 at 11:37:00AM +0200, Mathieu Malaterre wrote:
> On Thu, Jun 9, 2011 at 11:27 PM, Andreas Tille <andreas@an3as.eu> wrote:
> > On Thu, Jun 09, 2011 at 01:02:56PM +0200, Sven Joachim wrote:
> >> >> The problem is that libdl.so has been moved to the multiarch paths in
> >> >> libc6-dev 2.13-5.  You must upgrade cmake to 2.8.4+dfsg.1-3, have you
> >> >> done that already?
> >> >
> >> > I'm building an unstable pbuilder chroot.  It is using the cmake
> >> > version you are mentioning:
> >> >
> >> > $ grep cmake.2\.8 ginkgocadx_2.4.1.1-1_amd64.build
> >> > Unpacking cmake (from .../cmake_2.8.4+dfsg.1-3_amd64.deb) ...
> >>
> >> Might be worth retrying with cmake 2.8.4+dfsg.1-4, currently in
> >> incoming.  It has a different multiarch implementation.
> >
> > $ grep cmake.2\.8 ginkgocadx_2.4.1.1-1_amd64.build
> > Unpacking cmake (from .../cmake_2.8.4+dfsg.1-4_amd64.deb) ...
> > I: new cache content cmake_2.8.4+dfsg.1-4_amd64.deb added
> >
> > No change. :-((
> >
> > Any further hint?
> I think the issue is being worked on at the moment upstream:
> http://public.kitware.com/Bug/view.php?id=12037#c26801
> ...
> Modestas Vainius wrote:
> 2) Will those patches be part of 2.8.5? I want to emphasize that
> released Ubuntu 11.04 (natty) already has this multiarch enabled so
> upstream cmake up to and including 2.8.4 is basically unusable on
> those systems. That's because libc6 package is multiarch enabled and
> e.g. vanilla cmake 2.8.4 is not even able to set CMAKE_DL_LIBS
> properly.
> ...
> IMHO cmake (current git master) does not handle this new libc6 layout
> for multiarch support

I tried to rebuild gofigure2 (which is affected by #629815) now I do
not get the 

   No rule to make target `/usr/lib/libdl.so', needed by `lib/libvtkRenderingAddOn2.so.0.8'

any more but rather

   No rule to make target `/usr/lib/libXt.so', needed by `lib/libPoissonReconstruction.so.0.8'

and thus I assume my action to reopen #630167 (which is unfortunately
not properly documented in the bug log) was not the right thing to do.
It rather seems that certain library packages need to be adapted to
the multiarch build and libc6-dev *now* works together with cmake but
libxt-dev does not.

Similarly I can confirm that when trying to build ginkgocadx I do not
run any more in the missing libdl.so but rather into

   No rule to make target `/lib/libwrap.so.0', needed by `src/cadxcore/libCADxCore.so.'

which somehow smells like libwrap0 is guilty for the problem.  I admit
that this multiarch stuff is above my horizon and I hope that somebody
might be able to clarify what might be the correct way of action now.
Kind regards



Reply to: