[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Missing dependency in Cufflinks package


I'm trying to backport Cufflinks to Ubuntu Lucid 10.04. I see there is
a work in progress for a Debian package here:

I'm in the process of learning the best/easiest way to build packages,
as I would love to be able to help in the future. Right now I'm trying
to use pbuilder to make sure it builds in a clean system. I've also
read http://debian-med.alioth.debian.org/docs/policy.html#git-tips,
but I ran into some troubles mostly because of my lack of knowledge
about git.

sudo DIST=lucid pbuilder build cufflinks_1.0.3-1ppa1~lucid1.dsc

I found this error (maybe missing zlib1g-dev dependency):
In file included from /usr/include/samtools/bam.h:52,
                 from conftest.cc:17:
/usr/include/samtools/bgzf.h:29:18: error: zlib.h: No such file or directory

I was able to test that adding zlib1g-dev as a dependency for the
source package solved this error.

Thanks for your hard work.
Carlos Borroto
Baltimore, MD

Reply to: