[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need some help with EMBOSS, that links to too many libraries.

On Tue, Aug 10, 2010 at 09:58:12PM +0900, Charles Plessy wrote:
> I have problems with controlling how the emboss packages are linked to libraries.
> As you can see in http://bugs.debian.org/558852: 

I might try to have a look into this but forewarding this problem to
debian-mentors (or debian-devel) comes to mind as well.
> Here are the possible solutions:
>  - Remove the EMBASSY packages from testing.
>  - Upload EMBOSS 6.2 to testing-proposed-updates.
>  - Upgrade embassy packages with the latest upstream version, that builds
>    against EMBOSS 6.3.
> I would have a strong preference for upgrading all to 6.3 (that support SAM
> format???a must in 2010) and negociate with the release team for a freeze
> exception,

As far as I understood the release managers on in the DebConf BOF there
is a good change for this option and it would be my preference as well.
I would talk to them rather sooner than later about their opinion (even
before we might have applied the final polishing) because they might
start some rounds of removing packages from testing to reduce the bug
count.  So it would be a good idea to uncover your intent soon that they
do not spend their time with useless removal and later insert it again.

> but in that case I think that the packages really need to be high
> quality, which in my opinion means fixing the emboss packages so that the
> embassy packages do not need to build-depend on libpq-dev and
> libmysqlclient-dev.

In principle I do not really see why an additional Build-Depends might
really harm as long as the final package does not contain useless
Kind regards



Reply to: