[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Sarge LSB 2.0 results

> lsb-test-pam 
> <http://support.xandros.com/lsb/2005-06-15-lsb-test-pam-2.0-debian-sarge>

/tset/LSB.pam/testcases/pam_acct_mgmt/pam_acct_mgmt 4 FAIL
/tset/LSB.pam/testcases/pam_acct_mgmt/pam_acct_mgmt 5 FAIL

These fail if the additional test users (vsx1 and vsx2)
aren't set up right.  Make sure these accounts actually
have the passwords that have been supplied during the
setup interview.  It's not clear that rerunning the test
will work - looks like the accounts are left in a state
that is not the same as the initial state, and the set
of "chage" calls in the setup script are run only once,
the first run after installation.  That's been addressed
in the 3.0 tests recently, but nobody's had a chance to
backport to lsb-test-pam 2.x yet.

These problems may end up cascading through to other
tests as well.  We've seen this same set of 10 fails:

/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 1 FAIL
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 2 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 3 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 4 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 5 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 6 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 7 UNINITIATED
/tset/LSB.pam/testcases/pam_chauthtok/pam_chauthtok 8 UNINITIATED
/tset/LSB.pam/testcases/pam_setcred/pam_setcred 1 UNINITIATED
/tset/LSB.pam/testcases/pam_setcred/pam_setcred 2 UNINITIATED

recently, even in 3.0 testing. Not very helpfully, I don't
recall where they come from but they're familiar. I'm going to
check into it.

Reply to: