[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#683240: Proposed fix

package live-boot
severity 683240 important
tag 683240 + patch


I ran into the same problem, so I looked and I fixed it. Basically, in netboot mode the function do_netsetup() from the initrd /lib/live/boot/networking.sh tries to configure each interface listed in $DEVICE, but this list is empty, so it configured zero interface.

The interface selection was done before by Select_eth_device() from /lib/live/boot/select-eth-device.sh, which is called by mountroot() from /lib/live/boot/mountroot.sh, so we can use it here by sourcing /conf/param.conf where $DEVICE is saved.

This patch is a git-formatted one, based at debian/3.0_a35-1 so that it can be applied to the current testing version, but it can apply to the unstable version as well (better do that with a merge however, if you ask me). I cannot consider this bug as grave, but I still think it should really get fixed in testing, to avoid releasing a Debian Live which would be unusable in netboot mode, you may want to ask the release team about that.


: /` )   Tanguy Ortolo      <xmpp:tanguy@ortolo.eu>
| `-'    Debian Developer   <irc://irc.oftc.net/Tanguy>
�d�`�$�8'�,�^5[����3����_���έ�^7+bI�&�t<��B��~����7�\�w�W�5(�Kc<�M�B,J��љWAmE��oT�G����}�w$j!�+A9�ɪ��[����/�%��/ђ,�:�:���5��p#������y�R���=��؟���5͖XU=0����	��P�~-�\�o,���$Xn�Ic����h����o��Tּ%T�����Oo=^*�ue�:Mc3>ŗ�%����ֈ�>:�b��UC9��o������'���-I�"�;�s�m���q��׊��cn8�����|K,B��;�|�؛p$<�Th�'���iq�AE,�(��U��! m�%]L���h�c!rUE+:Q�>�H^r�GIg����~�[����i�|����pt,��P���C�p�k��ꂨ>�;�I���������t����f�������Q_޻C�ծ�yA��$U�+D���/�����<"�t-nI#�N(����<{Ǝ���>�Ɠ8M��

Attachment: signature.asc
Description: Digital signature

Reply to: