[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Stuck on "Configure the package manager" in installer within gnome/lxde live image

Thanks for your reply, Ben.

On Tue, May 31, 2011 at 4:02 PM, Ben Armstrong <synrg@sanctuary.nslug.ns.ca> wrote:
Unfortunately, what you're probably running into is a battle between the
live image and the installer about what to do with the network. The live
image will configure the network one way (usually NetworkManager), then
the installer will attempt to configure it its own way (using ifupdown,
dropping connection in the live system).

That was my thought too. But I could ping www.google.com from both a normal terminal and from inside a "chroot /live/installer /bin/sh" (after I 'cp /bin/ping /live/installer/bin/') There doesn't seem to be any network problems that I can find.

Now that I've discovered that /live/installer is where its all going on, (and I have my familiar /target mount), I could make headway. It turns out that once inside /live/installer, /usr/bin/apt-setup eventually gets called. It in turn calls /usr/lib/apt-setup/generators/50mirror which does this, which fails:

db_metaget apt-setup/use/netinst description

That causes 50mirror to fail and exit with $? = 10 because of set -e. apt-setup "handles" that, but eventually also exits with exitcode 10. That is why I'm seeing the problem. If I change that exit to exit 0, it continues. I didn't manage to fiddle enough with debconf to get it to actually configure the mirror.

So my question is now reduced to: Why does "db_metaget apt-setup/use/netinst description" fail? Shouldn't the apt-setup package have "populated" debconf with that info? (I'm not incredibly strong on debconf...)

When I run this script:

set -e
. /usr/share/debconf/confmodule
logger -t debug before get
db_metaget apt-setup/use/netinst description
logger -t debug after get

I get the "after get" line in /var/log/syslog when i run it in the text installer boot option from the same ISO (that works), but I don't get it when I run the installer from inside the live image.

So something is funky with the debconf database, but only when the installer is run from inside the live image. Is that a valid assessment? Any idea what should be done about it?

Peter Valdemar Mørch

Reply to: