[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#578136: live-initramfs failing to mount filesystem.squashfs in Debian Live Squeeze 6.0alpha1 CD image

Package: live-initramfs

Downloaded image from here:

All md5sums check out ok at all stages.

Then undertook following steps:
1. Mounted image and copied all contents (including .disk directory)
to third partition of flash drive.
2. Changed name of isolinux directory and isolinux.cfg to syslinux;
edited all configuration files in isolinux directory to say "syslinux"
in path; did not change name of isolinux.bin.
3. Installed syslinux from Puppy Linux on to boot record of this partition.
4. Included stanza in Grub on MBR of flash drive to boot from
partition using chainloader.

This procedure has worked fine with seven other Live CD images so far,
including three other Debian Live images (LXDE and GNOME versions for
Lenny from Debian Live site; Debian Eee 1.0b3 image, based on
Squeeze).  All have booted normally and allowed me to run persistent

Upon boot, main menu is presented.  Choosing option for "Live" or
"686" (and possibly all other options as well, have not tried)
initiates boot sequence.  Just after the line "squashfs 4.0" appears,
boot process halts with this message:

Can not mount /dev/loop0 (/live/image/live/filesystem.squashfs) on

The file live.log that is created contains this:

Mounting "/live/image/live/filesystem.squashfs" on "filesystem.squashfs"
via "/dev/loop0" ... mount: mounting /dev/loop0 on //filesystem.squashfs
failed : Invalid argument

I rechecked all checksums, they check out.  In case it was a version
mismatch I ran "file filesystem.squashfs" from Puppy Linux and got

/mnt/cdrom/live/filesystem.squashfs: Squashfs filesystem, little
endian, version 4.0, -1880381185 bytes, 149287 inodes, blocksize: 66
bytes, created: Thu Nov 10 06:08:16 1938

So it appears to be a 4.0 squashfs file, which should mount (and
incidentally does mount from Puppy).

Bug 540000 appears to describe a similar event but this was closed
without resolution.  There is also a similar discussion at
but this too did not seem to have been resolved.  Both earlier reports
are much older.

Reply to: