[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

net boot router

Hi all!

I need  help from you. Even if this problem is out of this
project, some hints may help.

This is very strange problem. I have net boot setup working fine
for a half year at lest. I am using it mostly for test purposes
as diskless workstation. The file system (installed packages)
auto-upgraded every day, while kernel and initrd upgraded
manually sometime.

Last Friday I try to use it as router with 3 interfaces and it
fail. The problem is that when kernel boot, before mount root
fs the interface switch to half-duplex. This break connection
and thus booting can not continue. The wonder is that if I remove
two interfaces it booted successfully. Moreover, this router
booting normally from disk with all of those three interfaces.
The same true for the debian installer booted from network (pxe
boot). That is why, I think this problem in some way concerned
with debian-live. But I don't understand how.

What I have tried. All of those interfaces are 3c905 100Mbit
pci cards. Turn off auto-negotiation and force full-duplex in
the cards bios don't help. Force different interrupts levels for
network cards in the system bios don't help. Kernel options
noacpi and noapic don't help. The same result for different
kernels: 2.6.18-4-686, 2.6.22-3-686, 2.6.22-3-486

Any ideas welcome.


****   Vladimir Stavrinov  ******
*******   vs at inist.ru   ******

Reply to: