[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

persistent option

On Thu, Jun 28, 2007 at 04:42:40PM +0100, neuhoff at mhccorp.com wrote:
> First of all, does your computer BIOS support booting from a USB stick at all?
> Also, have you made sure that your partition (should be the first one on your 
> USB stick of filesystem type 'vfat', normally seen as '/dev/sda1' by Linux) 
> is marked as bootable? You can use fdisk to achieve this.
> Finally, do a 'syslinux /dev/sda1' from your root account to make sure it has 
> a correct MBR.

Sorry, I've been misunderstood. 
I'm booting from CD, and I want to achieve persistency trough a usb

I tried the live CD with qemu, and I used -hda hand_made_vfat_image
and it worked placin into it the cpio file created by casper-snapshot or
live-snapshot. It worked perfectly.

Then I tried with my real hardware. I booted from the CD, I created a
new file one the desktop, issued live-snapshot, copied the cpio file on
the usb stick, unmounted it and rebooted with the stick in.

After the reboot the file I created was not on the desktop. I'll have
users that can't format the usb stick with ext2 or relable it, but from
the wiki I understood it is not necessary (and in fact, just putting the
file there worked using qemu).

How can I trace this problem? can It be that the usb device is
"discovered" late? I'm pretty sure that during boot, the kernel prints
something about usb device exactly at the beginning of the squash-fs
loading (the operation that takes some time). Can it be a rece
condition? Am I doing something wrong?

Thanks for the help.
Enrico Tassi

Reply to: