[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Plugins, libraries, licenses and Debian

Glenn Maynard <g_deb@zewt.org> writes:

> On Mon, Dec 08, 2003 at 03:09:06PM -0500, Brian T. Sniffen wrote:
>> Ah, found it -- Debian KDE list, late July 2002: Konqueror doesn't
>> link against OpenSSL.  It runs a separate process (kcm_crypto, it
>> looks like), which links against openssl... but does so in a way that
>> *doesn't* invoke OpenSSL's advertising clause.  Thus, the GPL
>> prohibition on additional restrictions isn't invoked, and what KDE's
>> doing is fine.
> I don't quite follow.  It doesn't matter if extra restrictions are
> invoked or not; they're GPL-incompatible regardless.  ("Don't use this
> software to make bombs" is GPL-incompatible, even if you don't happen to
> be using it to make bombs.)
> Could you link to the thread you're referencing?

Sure.  It starts with 



Reply to: