[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Corel's apt frontend



On Mon, Nov 01, 1999 at 02:34:03AM -0500, Raul Miller wrote:
> > The QPL does not require patches. It prefers them, but doesn't require
> > them. You could just as easily provide the original for reference and
> > let someone else diff it (which is at least a major improvement over
> > requiring that only patches be made..)
> 
> Ok, thanks, I wasn't up on that.
> 
> But basically what this means, you're obligated to distribute all prior
> versions -- perhaps as a CVS archive, perhaps as something less efficient.
> [If you're the author you can collapse versions, but not if you're
> building on someone else's work.]
> 
> Not that I particularly care..

Just their latest release.  It's at least an improvmenet over patches, but
I could have done better if their lawyer hadn't decided that was necessary
or anything like that.

And as everyone has pointed out several times it'd be a lot simpler for
everyone if they used the GPL or something simple like that.  I'm not
convinced the GPL is ideal, it just seems more ideal than other things and
it's the fastest way to fix a few of the IMO bugs in the QPL.

I take full responsibility for at least one of those bugs, but I've gone
into detail what the problem was and what the Trolls oughtta do to fix it
in other messages.

-- 
- Joseph Carter         GnuPG public key:   1024D/DCF9DAB3, 2048g/3F9C2A43
- knghtbrd@debian.org   20F6 2261 F185 7A3E 79FC  44F9 8FF7 D7A3 DCF9 DAB3
--------------------------------------------------------------------------
* Simunye is on a oc3->oc12
<daem0n> simmy: bite me. :)
<Simunye> daemon: okay :)

Attachment: pgp0jBn4EjyuQ.pgp
Description: PGP signature


Reply to: