[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: no graphics for Debian buster on Dell Inspiron

On 11/20/19 3:42 AM, Matteo Semplice wrote:
On 16/11/19 23:08, eric wrote:
On 11/16/19 9:22 AM, Matteo Semplice wrote:

after nearly 20 years of happiness with Debian distros I am struggling to get Debian buster working on a Dell Inspiron 14 2-in-1.

The installer completes, but I have no working wifi and no working graphics.

Let's concentrate on the graphics for now, since it is more urgent. The laptop has an i7-10510U which should come with an embedded UHD 620 graphics and also a discrete nVidia MX230 GPU. I have tried following different ideas found on the web but with no luck. My guess is that the embedded graphics is not recognized by the driver and that MX230 does not work with nouveau, but here are some details. The following tests have been done on a fresh install (kde task selected in the installer with only firmware-nonfree, firmware-iwlwifi added afterwards).

On a side note, I have tried to upgrade the kernel to the 5.2 in buster-backports but both bop.2 and bop.3 packages result in unbootable kernels: the boot process just hangs somewhere. I have uninstalled them, but if you think that a newer kernel may help I can try to reinstall and boot it without the quiet option to see what goes wrong.

Thanks in advance for any suggestion.


?????? Matteo

I have little experience in this regard but do have a cybertron laptop with the hybrid intel/nvidia graphics.

There is a lot of confusing information on the web.?? I would start with blacklisting the nouveau driver and removing all the nvidia drivers to see if you can get just the intel graphics to work.




??thanks for the tip! You've put me in the right direction and I've also done further research: in the end it seems that it is the i7-10510U cpu that is not yet fully supported.

At present, I can boot 5.2 and 5.3 kernels from buster-backports and sid provided that I blacklist the intel_lpss_pci and the nouveau module. (After boot I have tried to modprobe nouveau and it seems ok, but I have not tested much as for now I just need to have the machine up and running with just any graphics user interface).

It's not clear to me if better support for my Comet Lake i7-10510U will be granted by the same Ice Lake patches expected in kernel 5.4 or not, but I guess that I just need to wait few more days.

For reference, I just report here the link to this reddit about installing on XPS 13 (which has an Ice Lake cpu)


I have taken from there the idea to blacklist the lpss driver; I'll test some of the other tips given there and report back.


?????? Matteo

Glad to hear you are making progress. I never would of thought about the cpu not being fully supported.

I hope you get your machine working soon.



Reply to: