[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Multimedia/Volume Keys Not Working

On February 11, 2013 05:42:16 PM Harvey Kelly wrote:
> Hi everyone,
> Running Wheezy and the multimedia/volume keys don't work in
> Windowmaker (they work fine with Gnome and Xfce4), nor from the
> console.
> Using xev, it seems they've been mapped correctly (from an Arch wiki
> page I ran this command):
> xev | grep -A2 --line-buffered '^KeyRelease' | sed -n '/keycode
> /s/^.*keycode \([0-9]*\).* (.*, \(.*\)).*$/\1 \2/p'
> Which gave me the output:
> 123 XF86AudioRaiseVolume
> 122 XF86AudioLowerVolume
> 121 XF86AudioMute
> The Debian wiki (http://wiki.debian.org/Keyboard/MultimediaKeys)
> suggests mapping them with xmodmap - but that seems a little
> redundant/wrong if xev is telling me they're already mapped (same with
> xloadkeys).
> I've tried installing/purging everything to do with Gnome (to get rid
> of specifically pulseaudio), but that doesn't make any difference - l
> even uninstalled ALSA and reinstalled with no joy.
> Other function keys like brightness/dimming work fine, it's just the
> volume up/down/mute that aren't working.
> The card (according to alsamixer is a HDA Intel / Intel Cantiga HDMI).
> Any help would be really appreciated.
> Harvey

Hi Harvey,

I think your problem may occur because you have nothing listening to those key 
strokes.  Gnome, Xfce 4, and other DE's have programs that listen for those 
key presses and respond accordingly.  It shouldn't be realted to either ALSA 
or pulseaudio.  Do you have an appropriate program running that listens to 
them (I've never used Windowmaker, so I don't know what it would use)?


Reply to: