[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lenovo T520i X11 Intel i810 "static display" issue

On 08/16/2011 08:25 AM, keitho@strucktower.com wrote:
In response to a previous thread:

Dr. Mobius, Bill Brelsford, et all:

Did anyone find a solution or even a cause for this "static display"
problem upon resume from suspend?

I see that Martin Steigerwald claims that upgrading to 3.0 solves the
problem, but it hasn't solved the problem for me- I am running 3.1.0-rc1
with all upgraded packages on my Thinkpad T520 and the problem persists.
In looking around on the Internet I see that others have the same problem,
and _sometimes_ upgrading mysteriously helps, but no one seems to know a
definitive answer.

I would appreciate any help anyone can offer.

The symptoms are that the display doesn't update -- while it's
viewable. There's no visible response to keyboard or mouse inputs.
  The pointer itself /does/ move around the display, but windows
don't take focus, won't resize or move, etc.

However if I toggle away (<shift><alt><F1-6>) then back to
(<alt><F7>  or<alt><F8>) the display -- the changes /are/
reflected.  I've taken advantage of this to shut down windows/apps

If i restart X ("sudo /etc/init.d/kdm stop; sudo /etc/init.d/kdm
start" from another virtual console), X works properly, usually.

I've noticed this under several desktops / window managers (GNOME,
KDE, XFCE, twm, wmaker).  It doesn't appear to be specific to the
window manager.

Restarting the window manager doesn't clear the behavior.


Wow! I wish I knew of a way to help. I just got a T520i (Core i3 processor). I installed testing on it with linux-image-2.6.39-2-amd64. That has since been upgraded to 3.0.0+39 with the old image being removed. The first kernel worked perfectly for me. Only display issues on this are the ones common to all of my testing systems -- GTK and QT apps run via SSH -X session on remote systems show some minor but annoying corruptions. But I haven't seen any GUI responsiveness issues (on local or remote apps) like the ones you mention.

I have to wonder if this is a driver issue for a specific video subsystem that you folks are seeing.

Reply to: