[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Laptop detects only part of the RAM memory

On Mon, Sep 28, 2009 at 08:33, Imre Vida <I.Vida@bio.gla.ac.uk> wrote:


may be a very trivial  question, but have you switched to
4 GB under "Processor type and features/High Memory Support"
in the kernel config?


Hello Imre,

indeed, I had *not* switched to 4 GB.  It was very trivial, and in the past I did had 4GB set.  At some point I must have changed it (I don't recall doing it, but I did it anyway), and since I previously had it set to 4GB, I did not think of that.  Then, probably, even if I saw it, I overlooked it, since I mistakenly thought that the 4GB setting was for 4GB or more.

Once I set the switch to 4 GB all my RAM "returned" ;)

Thank you for your reply.



On Sat, Sep 26, 2009 at 03:44:15PM +0200, j.andradas@gmail.com wrote:
>    Hello,
>    last week, when booting a virtual machine, I discovered that my laptop
>    only recognizes one of the RAM modules (supposed to be 1 GB, but truly
>    providing 880 MB).  I realized this when VirtualBox complained that I had
>    configured more than the available RAM to the virtual machine.  I had not
>    changed the virtual machine configuration, and the virtual machine had
>    about 950 MB assigned (and my physical host, only had 880 MB).
>    Since I previously had 2 GB of RAM, I assumed one of the chips was broken
>    somehow.  I replaced one of them, and I still got this output for the
>    "free" command:
>    $ free
>                     total       used       free     shared    buffers
>    cached
>    Mem:        902264     892608       9656          0      23624     621432
>    So I put the original module back on, and changed the other one.  I
>    entered the BIOS, and it detected 2048 MB of RAM.   I run a test on the
>    memory (from the BIOS), and everything seemed allright.  But my Debian
>    keeps seeing only 902264 of RAM.
>    I downloaded a new Kernel, re-compiled, but everything is still the same.
>    I am running Debian Sid, if that could matter, but I can't see how that
>    would affect the amount of RAM available.
>    Running lshw, I get the following ouput:
>         *-memory
>              description: System Memory
>              physical id: a
>              slot: System board or motherboard
>              size: 2GiB
>            *-bank:0
>                 description: SODIMM DDR2 Synchronous 533 MHz (1.9 ns)
>                 product: 9905293-014.A00LF
>                 vendor: 7F98000000000000
>                 physical id: 0
>                 serial: 41CC9DE7
>                 slot: DIMM #1
>                 size: 1GiB
>                 width: 64 bits
>                 clock: 533MHz (1.9ns)
>            *-bank:1
>                 description: SODIMM DDR2 Synchronous 667 MHz (1.5 ns)
>                 product: 9905295-066.A00LF
>                 vendor: 7F98000000000000
>                 physical id: 1
>                 serial: 66078142
>                 slot: DIMM #2
>                 size: 1GiB
>                 width: 64 bits
>                 clock: 667MHz (1.5ns)
>    Could the difference between the clocks available on the RAM chips only
>    allow for one of them to be used?
>    Thank you in advance,
>    Best Regards,
>    --
>    Jonás Andradas
>    Skype: jontux
>    LinkedIn: http://www.linkedin.com/in/andradas
>    GPG Fingerprint:  678F 7BD0 83C3 28CE 9E8F
>                              3F7F 4D87 9996 E0C6 9372
>    Keyservers:  pgp.mit.edu | pgp.rediris.es

Imre Vida, M.D., Ph.D.
Division of Neuroscience and Biomedical Systems
IBLS, University of Glasgow
West Medical Building
Glasgow, G12 8QQ, U.K.
Tel.: 0044 141 330 5143
Fax.: 0044 141 330 5481
eMail: i.vida@bio.gla.ac.uk

To UNSUBSCRIBE, email to debian-laptop-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: