[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Laptop detects only part of the RAM memory


last week, when booting a virtual machine, I discovered that my laptop only recognizes one of the RAM modules (supposed to be 1 GB, but truly providing 880 MB).  I realized this when VirtualBox complained that I had configured more than the available RAM to the virtual machine.  I had not changed the virtual machine configuration, and the virtual machine had about 950 MB assigned (and my physical host, only had 880 MB).

Since I previously had 2 GB of RAM, I assumed one of the chips was broken somehow.  I replaced one of them, and I still got this output for the "free" command:

$ free
                 total       used       free     shared    buffers     cached
Mem:        902264     892608       9656          0      23624     621432

So I put the original module back on, and changed the other one.  I entered the BIOS, and it detected 2048 MB of RAM.   I run a test on the memory (from the BIOS), and everything seemed allright.  But my Debian keeps seeing only 902264 of RAM.

I downloaded a new Kernel, re-compiled, but everything is still the same.  I am running Debian Sid, if that could matter, but I can't see how that would affect the amount of RAM available.

Running lshw, I get the following ouput:

          description: System Memory
          physical id: a
          slot: System board or motherboard
          size: 2GiB
             description: SODIMM DDR2 Synchronous 533 MHz (1.9 ns)
             product: 9905293-014.A00LF
             vendor: 7F98000000000000
             physical id: 0
             serial: 41CC9DE7
             slot: DIMM #1
             size: 1GiB
             width: 64 bits
             clock: 533MHz (1.9ns)
             description: SODIMM DDR2 Synchronous 667 MHz (1.5 ns)
             product: 9905295-066.A00LF
             vendor: 7F98000000000000
             physical id: 1
             serial: 66078142
             slot: DIMM #2
             size: 1GiB
             width: 64 bits
             clock: 667MHz (1.5ns)

Could the difference between the clocks available on the RAM chips only allow for one of them to be used? 

Thank you in advance,

Best Regards,

Jonás Andradas

Skype: jontux
LinkedIn: http://www.linkedin.com/in/andradas
GPG Fingerprint:  678F 7BD0 83C3 28CE 9E8F
                          3F7F 4D87 9996 E0C6 9372
Keyservers:  pgp.mit.edu | pgp.rediris.es

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: