[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Smartlink modem driver doesn't send "RING" messages.


This is new behavior in the new Lenny installation.  Under Etch it worked
fine.  I have restored the same configuration files that worked before,
but now the modem never answers.  The following init-chat line used to work

init-chat "" AT+FCLASS=8 OK ATN1S0=0S13=1 OK

The S0 register is defined as "rings to auto answer".  If I'm not mistaken
vgetty takes control of the modem and generates an "A" command when it's
time to answer, after the number of rings specified in voice.conf.
S13=1 is echo commands.  I have also tried X0 and X1 in the init-chat
line, per the file smartlink_v92_12312001.pdf as found via google.

These are all the S registers that ati4 return:

s00=000 s01=000 s02=043 s03=013 s04=010 s05=008 s06=002 s07=060
s08=002 s09=006 s10=007 s11=100 s12=050 s13=001 s14=000 s15=001
s16=001 s17=000 s18=000 s19=000 s20=000 s21=000 s22=000 s23=000


And this is what the above file says they mean:

s00=000	Rings to auto-answer	rings	default=0
s01=000	Ring counter		rings	default=0
s02=043	Escape character	ASCII	default=43
s03=013	CR character		ASCII	default=13
s04=010	LF character		ASCII	default=10
s05=008	BS character		ASCII	default=8
s06=002	Wait time for dial tone	seconds	default=8
s07=060	Wait time for carrier	seconds	default=60
s08=002	Pause time for dial	seconds	default=2
s09=006	Carrier detect resp. t	0.1 s	default=6
s10=007	Carrier loss disc. t	0.1 s	default=7
s11=100	DTMF Tone Duration	0.001s	default=100
s12=050	Reserved
s13=001 Echo			0-1	default=1
s14=000	Quiet			0-1	default=0
s15=001	Verbose			0-1	default=1
s16=001	Pulse/Tone		0-1	default=1
s17=000	Reserved
s18=000	Test timer (0-255)	minutes	default=0
s19=000	Sys inactivity timer	minutes	default=0
s20=000	Reserved
s21=000 Break Length (0-9)	100ms	default=9
s22=000	Origin/answer (0-1)	0-1	default=0
s23=000	XOFF character		ASCII	default=19

Changing s0 and s22 (the only registers that could remotely be
applicable) changes nothing. 

>From the Etch vgetty, I remember that with each ring, "RING" showed up in
the log file.  Now nothing shows up.  A google search found a very similar
problem, from 2004, but no solution:


I have also connected to /dev/ttySL0 with kermit (that's how I got the
ati4 output above) and while calling the phone number no "RING" messages
are generated.  Yes, I have tested that the incoming wire does receive
the rings by plugging a phone in it.

This is the log file.  When vgetty used to work, I also had some (all?) of
these errors, but the modem answered.  This is a built-in modem in a
Dell 8600: sl-modem-source 2.9.9d+e-pre2-12 and sl-modem-daemon
2.9.9d+e-pre2-12 (that come with the Lenny distribution).

Can anyone provide a hint or solution?  Thanks.


02/16 23:18:28 SL0  reading program vgetty configuration from config file /etc/mgetty/voice.conf
02/16 23:18:28 SL0  reading port ttySL0 configuration from config file /etc/mgetty/voice.conf
02/16 23:18:28 SL0  check for lockfiles
02/16 23:18:28 SL0  locking the line
02/16 23:18:29 SL0  tio_get_rs232_lines: TIOCMGET failed: Invalid argument
02/16 23:18:29 SL0  WARNING: DSR is off - modem turned off or bad cable?
02/16 23:18:29 SL0  lowering DTR to reset Modem
02/16 23:18:29 SL0  TIOCMBIC failed: Invalid argument
02/16 23:18:29 SL0  send: AT+FCLASS=8[0d]
02/16 23:18:29 SL0  waiting for ``OK'' ** found **
02/16 23:18:29 SL0  send: ATN1S0=0S13=1[0d]
02/16 23:18:29 SL0  waiting for ``OK'' ** found **
02/16 23:18:29 SL0  send: AT[0d]
02/16 23:18:29 SL0  do_stat: expect 'OK' ** found **
02/16 23:18:29 SL0  send: ATI2[0d]
02/16 23:18:29 SL0  do_stat: expect 'OK' ** found **
02/16 23:18:29 SL0  mdm_send: 'AT+FCLASS=2' -> ERROR
02/16 23:18:29 SL0  detecting voice modem type
02/16 23:18:30 SL0  V253 modem detected
02/16 23:18:31 SL0  initializing V253 voice modem
02/16 23:18:32 SL0  vgetty: Modem returned ERROR
02/16 23:18:32 SL0  setting ringback delay didn't work
02/16 23:18:32 SL0  vgetty: Modem returned ERROR
02/16 23:18:33 SL0  waiting...

This is what gets logged in /var/log/statistics.ttySL0 

SmartLink Soft Modem, 2.9.9e-pre1
Smart Link Ltd.

Reply to: